What hardware do I need to use the AltspaceVR App for Gear VR?

You will need a Samsung Gear VR. We also support the Gear VR Innovators Edition.

Currently, we support the following models:

  • Galaxy S6
  • Galaxy S6 Edge
  • Galaxy S6 Edge +
  • Galaxy Note 5
  • Galaxy S7
  • Galaxy S7 Edge

Please be on Android 5.1.1 (Lollipop) or later. At this time, Galaxy Note 4 is not a supported device, due to hardware constraints.

As Samsung releases more compatible models we will update this article.

Have more questions? Submit a request
Powered by Zendesk